Sunum yükleniyor. Lütfen bekleyiniz

Sunum yükleniyor. Lütfen bekleyiniz

1 / 28 © TEMEL BİLGİSAYAR BİLİMLERİ – ELEKTRONİK TABLO- II Hafta 13 Elektronik Tablo – IV (Microsoft Excel) Konya, 2012 Temel Bilgisayar Bilimleri Dersi.

Benzer bir sunumlar


... konulu sunumlar: "1 / 28 © TEMEL BİLGİSAYAR BİLİMLERİ – ELEKTRONİK TABLO- II Hafta 13 Elektronik Tablo – IV (Microsoft Excel) Konya, 2012 Temel Bilgisayar Bilimleri Dersi."— Sunum transkripti:

1 1 / 28 © TEMEL BİLGİSAYAR BİLİMLERİ – ELEKTRONİK TABLO- II Hafta 13 Elektronik Tablo – IV (Microsoft Excel) Konya, 2012 Temel Bilgisayar Bilimleri Dersi

2 2 / 28 © TEMEL BİLGİSAYAR BİLİMLERİ – ELEKTRONİK TABLO- II GİRİŞ GİRİŞ Excel’de kendi oluşturduğumuz formülleri ve programda var olan işlevleri kullanarak veriler üzerinde çok farklı hesaplamalar yaptırabiliriz. Bu hesaplamalar toplama,çıkarma gibi dört işlemin yanı sıra,programda var olan işlevlerle standart sapma,korelasyon gibi daha karmaşık işlemler olabilir. FORMÜL VE FONKSİYONLAR

3 3 / 28 © TEMEL BİLGİSAYAR BİLİMLERİ – ELEKTRONİK TABLO- II FORMÜL VE FONKSİYONLAR Programda formüller oluştururken veya işlevleri kullanırken aşağıda belirtilen kurallara uymamız gerekir: Bütün formüller eşittir (=) işareti ile başlamalıdır. Formül yazarken karakterler arasında boşluk bırakılmamalıdır. Formülle bir hücredeki veri alınmak istendiğinde, eşittir işaretinden sonra hücre adresi yazılabilir veya fare ile ilgili hücreye tıklanabilir.

4 4 / 28 © TEMEL BİLGİSAYAR BİLİMLERİ – ELEKTRONİK TABLO- II FORMÜL VE FONKSİYONLAR Formülde metinler tırnak (“) içinde yazılır. Formülde parantez içindeki işlemler, parantez dışındaki işlemlere göre önceliklidir. Formül yazarken hücre içindeki değerleri yazmak yerine, hücre adresleri tercih edilmelidir. Böylelikle hücredeki veri değiştiği anda sonuç yeniden hesaplanacaktır.

5 5 / 28 © TEMEL BİLGİSAYAR BİLİMLERİ – ELEKTRONİK TABLO- II Formül sadece iki hücre ile ilgili olduğunda, hücre adresleri arasına noktalı virgül (;), iki hücre arasındaki hücrelerle ilgili ise adresler arasına iki nokta üst üste (:) koyulması gerekir. Örneğin B1 ile B2 hücrelerindeki değerleri toplamak istersek formül =Topla(B1;B2), B1 ile B9 arası tüm hücrelerdeki değerleri toplamak için ise, formül =Topla(B1:B3) olacaktır. FORMÜL VE FONKSİYONLAR AB =Topla(B1:B3) AB =Topla(B1;B2)

6 6 / 28 © TEMEL BİLGİSAYAR BİLİMLERİ – ELEKTRONİK TABLO- II FORMÜL VE FONKSİYONLAR İşaretİşlevİşaretİşlev +Toplama>Büyüktür -Çıkarma=Büyük Eşit /Bölme<=Küçük Eşit %Yüzde<>Eşit Değil ^Üs alma==Eşittir Formüllerde kullanılabilecek işaretler ve işlevleri aşağıdaki gibidir

7 7 / 28 © TEMEL BİLGİSAYAR BİLİMLERİ – ELEKTRONİK TABLO- II ARİTMETİK VE MANTIK FORMÜLLERİ Temel İşlemler Temel İşlemler C1 hücresine A1 ve B1 hücrelerindeki verileri toplamak istersek, C1 hücresine = yazılır. Sonuçta C1 hücresinde 110 değeri görünecektir. Hücre adreslerini kullanarak toplamak istersek, C2 hücresine =A2+B2 yazmamız gerekir. Yine C2 hücresinde 110 değeri görünecektir. Örnekler şekil1’de gösterilmiştir.

8 8 / 28 © TEMEL BİLGİSAYAR BİLİMLERİ – ELEKTRONİK TABLO- II ARİTMETİK VE MANTIK FORMÜLLERİ ABC = =A2+B = =A4-B =50* =A6*B =70/ =A8/B =90*25% =A10*25% ABC , , , Şekil 1. Temel İşlemler

9 9 / 28 © TEMEL BİLGİSAYAR BİLİMLERİ – ELEKTRONİK TABLO- II Farklı hücrelerdeki değerleri de toplatabiliriz. Bu durumda hücre adreslerini kullanmak daha açıklayıcı olacaktır. Örnek şekil2’de gösterilmiştir. ARİTMETİK VE MANTIK FORMÜLLERİ ABC 12090=A1+B1+B3+A5+B ABC Şekil 2. Farklı hücrelerdeki değerleri toplama

10 10 / 28 © TEMEL BİLGİSAYAR BİLİMLERİ – ELEKTRONİK TABLO- II Birden fazla işlem gerektiren formüller oluşturmak da mümkündür. Örneğin, A1 ile A4 hücrelerindeki değerleri toplayıp B1 ile B4 hücrelerinin toplamına bölmek istersek, formül şekil 3’teki gibi olmalıdır. ARİTMETİK VE MANTIK FORMÜLLERİ ABC , ABC 17010=(A1+A2+A3+A4)/(B1+B2+B3+B4) Şekil 3. Birden fazla işlem gerektiren formül

11 11 / 28 © TEMEL BİLGİSAYAR BİLİMLERİ – ELEKTRONİK TABLO- II ARİTMETİK VE MANTIK FORMÜLLERİ Yüzde İşlemi Yüzde İşlemi Bir hücredeki değerin yüzdesi alınmak istenirse örnek formül şekil 4’teki gibi olacaktır. AB 1240=240*25% 2240=A2*25% AB Şekil 4. Yüzde işlemi

12 12 / 28 © TEMEL BİLGİSAYAR BİLİMLERİ – ELEKTRONİK TABLO- II FONKSİYONLARLA ÇALIŞMAK Excel programında çok sayıda hazır işlev bulunmaktadır. Verilerimizin çok sayıda olduğu durumlarda bu hazır işlevleri kullanmak, işlemleri daha kolay ve hızlı yapabilmemizi sağlayacaktır. Formüller menüsündeki işlev ekle komutunu çalıştırdığımızda, şekil 5’teki İşlev Ekle penceresi karşımıza çıkacaktır. İşlev Ekle penceresine Shift +F3 kısayol tuşları ile de ulaşmak mümkündür.

13 13 / 28 © TEMEL BİLGİSAYAR BİLİMLERİ – ELEKTRONİK TABLO- II FONKSİYONLARLA ÇALIŞMAK Şekil 5. İşlev Ekle penceresi

14 14 / 28 © TEMEL BİLGİSAYAR BİLİMLERİ – ELEKTRONİK TABLO- II İşlev eklemek için bir diğer yol ise formül girilecek hücreye eşittir işareti girdikten sonra ad kutusundan yararlanmaktır. Eşittir işaretinden sonra şekil 6’daki ad kutusu en son kullanılan işlevlerin listesi haline gelecektir. Buradan da istenilen işlev seçilebilir. FONKSİYONLARLA ÇALIŞMAK Şekil 6. Ad kutusundan işlev ekleme

15 15 / 28 © TEMEL BİLGİSAYAR BİLİMLERİ – ELEKTRONİK TABLO- II FONKSİYONLARLA ÇALIŞMAK İşlev Ekle penceresinin işlev ara kısmına uygulamak istediğimiz formülün adını yazıp “Git” butonuna tıkladığımızda aşağıda ilgili işlevlerin listesi çıkacaktır. Kategori seçin kısmında yapılacak işleme uygun bir kategori seçtiğimizde aşağıya ilgili işlevlerin listesi gelecektir. Burada “tümü” seçeneği tercih edilirse programda mevcut olan tüm işlevler alfabetik olarak listelenecektir. İşlev seçin kısmında istenilen işlev seçilebilir.

16 16 / 28 © TEMEL BİLGİSAYAR BİLİMLERİ – ELEKTRONİK TABLO- II FONKSİYONLARLA ÇALIŞMAK Topla ve Çarpım İşlevi Topla ve Çarpım İşlevi Hücre içindeki değerleri =TOPLA(sayı1;sayı2) formülü ile toplayabilir, =ÇARPIM(sayı1;sayı2) formülü ile çarpabiliriz. Örnek formüller şekil7 ve şekil8’de gösterilmiştir. AB 15=TOPLA(A1;A2) 210 AB AB AB 15=ÇARPIM(A1;A2) 210 Şekil 8. Çarpım İşlevi Şekil 7. Topla İşlevi

17 17 / 28 © TEMEL BİLGİSAYAR BİLİMLERİ – ELEKTRONİK TABLO- II Karekök İşlevi Karekök İşlevi Hücre içindeki değerin karekökünü hesaplamamızı sağlar. Bunun için =KAREKÖK(sayı) formülü kullanılır. Şekil9’da formülün kullanımı gösterilmiştir. AB 1240=KAREKÖK(A1) AB ,49193 Şekil 9. Karekök İşlevi FONKSİYONLARLA ÇALIŞMAK

18 18 / 28 © TEMEL BİLGİSAYAR BİLİMLERİ – ELEKTRONİK TABLO- II Yuvarla İşlevi Yuvarla İşlevi Hücre içindeki değeri, istediğimiz basamak sayısı kadar yuvarlamamızı sağlar. Bunun için =YUVARLA(sayı;sayı_rakam) formülü kullanılır. Sayı_rakam kısmında virgülden sonra kaç basamağın yuvarlanılacağı belirtilir. Örnek şekil10’da gösterilmiştir. AB 110, ,52110,5 310,05110,05 410,952 AB 110,251=YUVARLA(A1;0) 210,521=YUVARLA(A1;1) 310,051=YUVARLA(A1;2) 410,952=YUVARLA(A1;3) Şekil 10. Yuvarla İşlevi FONKSİYONLARLA ÇALIŞMAK

19 19 / 28 © TEMEL BİLGİSAYAR BİLİMLERİ – ELEKTRONİK TABLO- II Min( En küçük değer) ve Mak(En büyük değer) İşlevi Min( En küçük değer) ve Mak(En büyük değer) İşlevi Seçili alandaki hücre değerlerinden en büyüğünü bulmamızı sağlar. Verilerin çok fazla olduğu durumlarda aradığımız değeri daha kolay ve çabuk bulmamızı sağlayan bir işlevdir. Örneğin A1 ile A150 arası hücrelerdeki değerlerin en küçüğünü ve en büyüğünü bulmak istiyoruz. Bunun için =MİN ve =MAK formülleri kullanılır. Örnekler şekil11 ve şekil12’de gösterilmiştir. AB 110,251=MİN(A1:A4) 210, , ,952 AB 110,25110, , , ,952 Şekil 11. MİN(En küçük değer) işlevi FONKSİYONLARLA ÇALIŞMAK

20 20 / 28 © TEMEL BİLGİSAYAR BİLİMLERİ – ELEKTRONİK TABLO- II AB 110,251=MAK(A1:A4) 210, , ,952 AB 110,25110, , , ,952 Min( En küçük değer) ve Mak(En büyük değer) İşlevi Min( En küçük değer) ve Mak(En büyük değer) İşlevi Şekil 12. MAK(En küçük değer) işlevi FONKSİYONLARLA ÇALIŞMAK

21 21 / 28 © TEMEL BİLGİSAYAR BİLİMLERİ – ELEKTRONİK TABLO- II Ortalama İşlevi Ortalama İşlevi Belirtilen hücrelerdeki değerlerin ortalamasını bulmaya yarayan işlevdir. Aynı formülde toplama ve bölme işlemlerini içermektedir. =ORTALAMA(sayı1;sayı2) formülü kullanılır. Örnek şekil13’te gösterilmiştir. ABCD 1123=ORTALAMA(A1;B2;C3) ABCD Şekil 13. Ortalama İşlevi FONKSİYONLARLA ÇALIŞMAK

22 22 / 28 © TEMEL BİLGİSAYAR BİLİMLERİ – ELEKTRONİK TABLO- II Standart Sapma İşlevi Standart Sapma İşlevi Belirtilen hücrelerdeki puanların dağılımını betimleyen bir işlevdir. =STDSAPMA(sayı1;sayı2) formülü kullanılır. Örnek şekil14’te gösterilmiştir. AB , AB =STDSAPMA(A1:A4) Şekil 14. Standart Sapma İşlevi FONKSİYONLARLA ÇALIŞMAK

23 23 / 28 © TEMEL BİLGİSAYAR BİLİMLERİ – ELEKTRONİK TABLO- II Eğer İşlevi Eğer İşlevi FONKSİYONLARLA ÇALIŞMAK Eğer işlevi, belirtilen koşula bağlı olarak bir sonuç üretmemizi sağlar. Hücre içindeki değer koşula bağlı olarak iki değerden birini alır. Eğer işlevi; =EĞER(mantıksal_sınama;[eğer_doğruysa_değer]; [eğer_yanlışsa_değer] ) şeklindedir. Örneğin öğrencilerin devam durumları ile ilgili bir listeyi kullanarak otomatik olarak öğrencilerin durumlarını (devamlı,devamsız) olarak yazdıralım. Öğrencinin devamsız gün sayısı 20’ye eşit ve büyükse “devamsız”, 20’den küçükse “devamlı” yazacak mantıksal sınama formunu oluşturalım.

24 24 / 28 © TEMEL BİLGİSAYAR BİLİMLERİ – ELEKTRONİK TABLO- II AB 15 =EĞER(A1>=20;"Devamsız";"Devamlı") 23 =EĞER(A2>=20;"Devamsız";"Devamlı") 315 =EĞER(A3>=20;"Devamsız";"Devamlı") 416 =EĞER(A4>=20;"Devamsız";"Devamlı") 521 =EĞER(A5>=20;"Devamsız";"Devamlı") AB 15 Devamlı Devamlı 416 Devamlı 521 Devamsız FONKSİYONLARLA ÇALIŞMAK Eğer işlevi ile excel programında farklı işlemleri tek formül içinde birleştirmek de mümkündür. Örneğin öğrencilerin vize ve final notlarının belirli bir yüzdesini alarak üretilen sonucu mantıksal sınamaya tabi tutabiliriz. Şekil?’deki örnekte vize notunun %40’ını, final notunun %60’ını hesaplayıp bunların toplamını 60 değeri ile karşılaştıracak formül oluşturulmuştur. Şekil 15. Eğer İşlevi

25 25 / 28 © TEMEL BİLGİSAYAR BİLİMLERİ – ELEKTRONİK TABLO- II FONKSİYONLARLA ÇALIŞMAK Sonuçta öğrencinin ağırlıklı ortalaması 60’dan büyükse “geçti”, küçükse “kaldı” yazması sağlanmıştır. Örnek şekil16’da gösterilmiştir. ABC VİZEFİNAL =EĞER(((A1*0,4)+(B1*0,6))<60;"Kaldı";"Geçti") =EĞER(((A2*0,4)+(B2*0,6))<60;"Kaldı";"Geçti") =EĞER((A3*0,4)+(B3*0,6))<60;"Kaldı";"Geçti") =EĞER(((A4*0,4)+(B4*0,6))<60;"Kaldı";"Geçti") =EĞER(((A5*0,4)+(B5*0,6))<60;"Kaldı";"Geçti") ABC VİZEFİNAL Kaldı Geçti Geçti Geçti Kaldı Şekil 16. Eğer İşlevi ile Farklı İşlemleri Tek Formül İçinde Birleştirme

26 26 / 28 © TEMEL BİLGİSAYAR BİLİMLERİ – ELEKTRONİK TABLO- II Şimdi ve Bugün İşlevi Şimdi ve Bugün İşlevi Şimdi işlevi girildiği hücreye kullanım anındaki tarihin ve saatin, bugün işlevi ise günün tarihinin yazılmasını sağlar. Bunun için hücreye =ŞİMDİ() ya da =BUGÜN() formülü yazılarak Enter’a basılmalıdır. Örnek şekil17’de gösterilmiştir. AB 1=ŞİMDİ() 2=BUGÜN() AB : Şekil 17. Şimdi ve Bugün İşlevi FONKSİYONLARLA ÇALIŞMAK

27 27 / 28 © TEMEL BİLGİSAYAR BİLİMLERİ – ELEKTRONİK TABLO- II Birleştir İşlevi Birleştir İşlevi Farklı hücrelerdeki metinleri birleştirmek için =BİRLEŞTİR(metin1;metin2) formülü kullanılır. Aynı işlem işlev ekle penceresinin kategori kısmından metin seçip işlev seçin kısmında birleştir işlevi seçilerek de yapılabilir. Örnek şekil18’de gösterilmiştir. ABC 1EğitimFakültesi 2=BİRLEŞTİR(A1;B1) ABC 1EğitimFakültesi 2EğitimFakültesi Şekil 18. Birleştir İşlevi FONKSİYONLARLA ÇALIŞMAK

28 28 / 28 © TEMEL BİLGİSAYAR BİLİMLERİ – ELEKTRONİK TABLO- II Hafta 13 Elektronik Tablo – IV (Microsoft Excel) Konya, 2012 Temel Bilgisayar Bilimleri Dersi


"1 / 28 © TEMEL BİLGİSAYAR BİLİMLERİ – ELEKTRONİK TABLO- II Hafta 13 Elektronik Tablo – IV (Microsoft Excel) Konya, 2012 Temel Bilgisayar Bilimleri Dersi." indir ppt

Benzer bir sunumlar


Google Reklamları