Sunum yükleniyor. Lütfen bekleyiniz

Sunum yükleniyor. Lütfen bekleyiniz

02.09.2014Öğr. Gör. Feyza Tekinbaş Bilgisayar (2).

Benzer bir sunumlar


... konulu sunumlar: "02.09.2014Öğr. Gör. Feyza Tekinbaş Bilgisayar (2)."— Sunum transkripti:

1 Öğr. Gör. Feyza Tekinbaş Bilgisayar (2)

2 Öğr. Gör. Feyza Tekinbaş Bugün Neler Yapacağız?  Topla Fonksiyonu  Çarpım Fonksiyonu  Mak Fonksiyonu  Min Fonksiyonu  Mutlak Fonksiyonu  Mod Fonksiyonu  Karekök Fonksiyonu  Ortalama Fonksiyonu  Yuvarla Fonksiyonu  Zaman Fonksiyonları  Eğersay Fonksiyonu  Etopla Fonksiyonu  Eğer Fonksiyonu

3 Öğr. Gör. Feyza Tekinbaş Bilmemiz Gerekenler:  Formülden önce mutlaka “=“ konulmalıdır.  “:” Aralıktaki tüm hücrelerde işlem yapar.  “;” Belirtilen hücrelerde işlem yapar.  Formül yazılırken karakterler arasında boşluk bırakılmaz.  Formül yazarken açılan parantez sayısı kadar parantez kapatılmalıdır.

4 Öğr. Gör. Feyza Tekinbaş Formül Çoğaltma  Seçili olan hücrenin sağ alt köşesinde küçük bir kare vardır. Onun üzerine mouse ile gelindiğinde artı işareti siyah ince bir artı şeklini alır. Bu şekilde sol tuşu basılı tutularak aşağı hücrelere sürüklenirse, formül, sayı ya da metin çoğaltılmış olur. Seçili hücre Küçük kare ince siyah artıya dönüşünce hücre içindeki değerler çoğaltılır.

5 Öğr. Gör. Feyza Tekinbaş Hatalar  Hücrede “#AD” yazıyorsa komut hatası vardır.  Hücrede “####” yazıyorsa bu durum hücre içerisindeki değerin hücreye sığmadığını gösterir, hücreyi genişletmek gerekir.

6 Öğr. Gör. Feyza Tekinbaş Topla Fonksiyonu  Standart araç çubuğundaki otomatik topla (∑) işaretinden,  Formül ile: =TOPLA(B2:D2) B2 ile D2 arasındaki tüm hücreleri toplar. = TOPLA(B2;D2) Sadece B2 ve D2 hücresindeki değerleri toplar.

7 Öğr. Gör. Feyza Tekinbaş Çarpım Fonksiyonu  =A5*A11 Hücreye bu şekilde yazılıp Enter tuşu ile onay verildiğinde A5 ve A11’deki değerlerin çarpımına ulaşılır.  =ÇARPIM(A5:A11) A5 ile A11 arasındaki değerleri çarpar.  =ÇARPIM(A5;A11) Yalnızca A5 hücresindeki değerle A11 hücresindeki değeri çarpar.

8 Öğr. Gör. Feyza Tekinbaş Örnek 1: Sipariş Tablosu

9 Öğr. Gör. Feyza Tekinbaş Mak Fonksiyonu  Belirtilen aralıktaki sayıların en yüksek olanını verir.  =Mak(A2:C30) A2 ile C30 hücreleri arasında en yüksek değere sahip olan hücrenin değerini gösterir.  =Mak(A2;A30) A2 ve A30 hücresindeki değerlerden hangisi daha yüksekse o hücredeki değeri gösterir.

10 Öğr. Gör. Feyza Tekinbaş Min Fonksiyonu  Belirtilen aralıktaki sayıların en küçük olanını verir. =MİN(A4:C4) şeklinde formüle edilir.

11 Öğr. Gör. Feyza Tekinbaş Soru:  Örnek 1’deki tabloyu dikkate alarak: En fazla miktarda ve en az miktarda sipariş edilen malzemeler hangileridir? Sipariş verilen malzemelerden birimi en pahalı ve en ucuz olanı hangileridir? Tutarı en fazla ve en az olan malzemeler hangileridir?

12 Öğr. Gör. Feyza Tekinbaş Mutlak Fonksiyonu  Belirtilen sayının mutlak değerini bulmak için kullanılır. Sayı direk yazılabildiği gibi hücre adresi de gösterilebilir. =Mutlak(4) -> 4 =Mutlak(-4) -> 4 Gibi…

13 Öğr. Gör. Feyza Tekinbaş Mod Fonksiyonu  Verilen sayıyı, verilen bölene böldükten sonra kalanı verir. =Mod(Sayı;Bölen) =Mod(4;2) -> Sonuç sıfırdır (0). =Mod(16;3)-> Sonuç birdir (1).

14 Öğr. Gör. Feyza Tekinbaş Karekök Fonksiyonu  Verilen pozitif bir sayının karekökünü bulur. =Karekök(Sayı) =Karekök(16) -> 4 olarak sonuç gelir. ya da =Karekök(A2) şeklinde yazılabilir.

15 Öğr. Gör. Feyza Tekinbaş Örnek 2: Mod ve Karekök Alma  Tablodaki değerlerin bölenin 3 olduğunu varsayarak modunu alınız.  Tablodaki değerlerin karekökünü hesaplayınız.

16 Öğr. Gör. Feyza Tekinbaş Ortalama Fonksiyonu  Belirtilen aralıkta bulunan hücrelerdeki değerleri toplar bunları kaç değer toplandıysa o sayıya böler.  =ORTALAMA(A4:A9) A4 ile A9 arasındaki değerlerin ortalamasını verir.  Fonksiyonu kullanmazsak; =(A4+A5+A6+A7+A8+A9)/6 şeklinde ya da =TOPLA(A4:A9)/6 şeklinde yazabiliriz.

17 Öğr. Gör. Feyza Tekinbaş Yuvarla Fonksiyonu  Bir malın miktarına ilişkin rakam ondalıklı değerlerle ifade edilemez. Örneğin 5,5 masa diyemeyiz.  Ya da virgülden sonra çok fazla basamak olan bir değerle karşılaşabiliriz ve bunu sadeleştirmek isteyebiliriz.  Bu iki işlemi de yuvarla fonksiyonunu kullanarak gerçekleştirebiliriz.

18 Öğr. Gör. Feyza Tekinbaş  Örneğin; Pi sayısını 22/7 şeklinde de ifade edebiliriz. Bu işlemin sonucu 3,142857’dir. Bunu virgülden sonra 2 basamak kalacak şekilde yuvarlamak istersek: =YUVARLA(22/7;2) yazabiliriz. Bu durumda sonuç 3,14 olacaktır. =YUVARLA(A5;0) yazdığımızı düşünelim. Bu durumda A5 hücresindeki ondalıklı değer virgülden sonraki basamak sayısı sıfır olarak belirtildiğinden bir doğal sayıya yuvarlanır. A5’deki değer 3,14 ise 3’e 3,54 ise 4’e yuvarlanır. Yuvarla Fonksiyonu

19 Öğr. Gör. Feyza Tekinbaş Aşağı Yuvarla Fonksiyonu  Verilen sayıyı istenilen sayıda aşağı yuvarlamak için kullanılır. =Aşağıyuvarla(23,56;0) -> 23 =Aşağıyuvarla(23,99;1) -> 23,9 Aşağı yuvarla komutunda sayı ne olursa olsun aşağı yuvarlanır!..

20 Öğr. Gör. Feyza Tekinbaş Yukarı Yuvarla Fonksiyonu Verilen sayıyı istenilen sayıda yukarı yuvarlamak için kullanılır. =Yukarıyuvarla(23,11;0) -> 24 =Yukarıyuvarla(23,99;1) -> 24 Yukarı yuvarla komutunda sayı ne olursa olsun yukarı yuvarlanır!..

21 Öğr. Gör. Feyza Tekinbaş Örnek 3: Dönem Notu Hesaplama  Yandaki tabloda isimleri ve notları verilen öğrencilerin: Vize ortalamalarını hesaplayınız. Vize notunun ağırlığı %40, final notunun ağırlığı %60 olacak şekilde dönem sonu notunu hesaplayınız. Notlar sisteme ondalıklı olarak girilemediğinden dönem sonu notunu yuvarlayınız.

22 Öğr. Gör. Feyza Tekinbaş Saat, Bugün, Şimdi, Gün, Ay, Yıl Fonksiyonları  =Saat(23:15:00) -> (23)  =Bugün() ->  =Şimdi() -> :19  =Gün( ) -> 07  =Ay( ) -> 11  =Yıl( ) -> 2005

23 Öğr. Gör. Feyza Tekinbaş Eğersay Fonksiyonu  Belirtilen aralıktaki değerleri belirtilen ölçütü sağlayan hücrelerin sayılmasını sağlar. =Eğersay(A1:A10;“10”) A1 ile A10 hücreleri arasında değeri 10 olan hücrelerin sayısını verir. =Eğersay(B3:B14;“Geçti”) B3 ile B14 hücreleri arasındaki hücrelerde değeri “Geçti” olanların sayısını verir. (Örnek 3 için yaptığımız tablodan yararlanacağız.)

24 Öğr. Gör. Feyza Tekinbaş Etopla Fonksiyonu  Belirtilen aralıktaki hücrelerden belirtilen şartı sağlaması durumunda belirtilen diğer hücrelerin toplamını verir. =Etopla(Sorgulanacak Hücre Aralığı;“Şart”;“Toplanacak Hücre Aralığı) =Etopla(A1:A10;“10”;B1:B10) A1 ile A10 arasında bulunan hücrelerin içerisinde 10 sayısı varsa o hücreye denk gelen B sütunundaki hücre değerlerini toplar.

25 Öğr. Gör. Feyza Tekinbaş Örnek 4: ETopla  Yandaki tabloda isimleri notları ve cinsiyetleri belirtilen kişilerin: Cinsiyeti kadın olanlar ve erkek olanların notları ayrı ayrı toplamayı etopla fonksiyonundan faydalanarak yapınız. Formül:  Erkeklerin not toplamı:=Etopla(D2:D5;“Erkek”;C2 :C5)  Kadınların not toplamı:=Etopla(D2:D5;“Kadın”;C2 :C5)

26 Öğr. Gör. Feyza Tekinbaş Eğer Fonksiyonu  Eğer fonksiyonu bir koşul söz konusuysa kullanılır.  3 bölümden oluşur: 1. Mantıksal sınama: Koşul verilen bölümdür. (A2>=50 gibi) 2. Eğer doğruysa değer: Mantıksal sınama ölümünde verilen koşulun gerçekleşmesi durumunda ekrana gelecek sonucun yazıldığı bölümdür. (Geçti) 3.Eğer yanlışsa değer: Mantıksal sınamada verilen koşulun gerçekleşmemesi durumunda ekrana yazılacak değerdir.(Kaldı)

27 Öğr. Gör. Feyza Tekinbaş Eğer Fonksiyonu  Excel’de Eğer komutu ile iç içe yedi formül yazılabilir.  Bunun için açılan parantezler kapatılmaz. Yani; =Eğer(Şart1;“Doğruysa değer1”;Eğer(Şart2; “Doğruysa değer2”;Eğer(Şart3;“Doğruysa değer3”))) Gibi… Yukarıda görüldüğü gibi açılan parantezler en sonda kapatılır.

28 Öğr. Gör. Feyza Tekinbaş Dikkat!..  Eğer bir işlem değil de bir isim ya da ifadeye göre koşul verilecekse,  Koşul gerçekleştiğinde ya da gerçekleşmediğinde hücreye yazılacak olan bir isim ya da ifade ise;  O İSİM YA DA İFADE MUTLAKA “TIRNAK” İÇİNE ALINMALIDIR

29 Öğr. Gör. Feyza Tekinbaş Soru:  Örnek 3’deki tabloyu kullanarak: Ortalama 50den küçükse KALDI arası ise ORTA arası ise İYİ 85’in üzerinde ise PEKİYİ yazacak şekilde tabloyu düzenleyiniz.

30 Öğr. Gör. Feyza Tekinbaş Örnek 3: Dönem Notu Hesaplama  Formül: =EĞER(G2<50;”kaldı”;EĞE R(G2<70;”orta”;EĞER(G 2<85;”iyi”;”pekiyi”)))

31 Öğr. Gör. Feyza Tekinbaş TEŞEKKÜRLER…


"02.09.2014Öğr. Gör. Feyza Tekinbaş Bilgisayar (2)." indir ppt

Benzer bir sunumlar


Google Reklamları