Sunum yükleniyor. Lütfen bekleyiniz

Sunum yükleniyor. Lütfen bekleyiniz

HESAP TABLOSU PROGRAMLARI BİLGİSAYAR ORTAMINDA YARATILAN ELEKTRONİK ÇALIŞMA SAYFALARI.

Benzer bir sunumlar


... konulu sunumlar: "HESAP TABLOSU PROGRAMLARI BİLGİSAYAR ORTAMINDA YARATILAN ELEKTRONİK ÇALIŞMA SAYFALARI."— Sunum transkripti:

1 HESAP TABLOSU PROGRAMLARI BİLGİSAYAR ORTAMINDA YARATILAN ELEKTRONİK ÇALIŞMA SAYFALARI

2 Formüllerle Çalışmak Microsoft Excel gelişmiş bir elektronik bir hesap tablosudur ve birçok işlemi yapabilmek için içerisinde birçok fonksiyon barındırır. Microsoft Excel’de herhangi bir hücreye formül girerken kesinlikle = işareti ile başlanmalıdır. Herhangi bir hücreye =5+10 formülünü girersek hücre otomatik olarak 15 değerini alacaktır. Microsoft Excel’in bir işlem yaparken kullandığı işaretler şunlardır; + Toplama - Çıkartma *Çarpma /Bölme ^ Üst Alma %Yüzde Hesaplama Aşağıda örnek birkaç işlem verilmiştir; =10+5sonuç 15 çıkacak =50-30sonuç 20 çıkacak =3*4sonuç 12 çıkacak =49/7sonuç 7 çıkacak =2^3sonuç 8 çıkacak =300*20%sonuç 60 çıkacak Microsoft Excel’de Çarpma ve Bölme işlemleri her zaman öncelik hakkına sahiptir. Eğer bir formül içerisinde aynı anda hem toplama veya çıkarma hem de çarpma veya bölme işlemleri varsa öncelik hakkı verilmek istenen işlemler parantezler “( ) “ içerisinde yazılmalıdır; Aşağıdaki örneklere dikkat ediniz; =10+20/2sonuç 20 çıkacak =(10+20)/2sonuç 15 çıkacak

3 UYGULAMA – 1 Microsoft Excel’de formül hazırlarken hücre isimleri referans olarak kullanılabilir. Aşağıda öğrenci notlarının girildiği bir tablo bulunmaktadır. D2 hücresi için=(B2+C2)/2 D3 hücresi için=(B3+C3)/2 D4 hücresi için=(B4+C4)/2 Bu formüllere göre D2 hücresinin değeri 85, D3 hücresinin değeri 75 ve D4 hücresinin değeri 65 olacaktır. Şimdi parantezlerin yerini değiştirerek hesaplamayı tekrarlayınız. =B2+ (C2/2) vb. gibi…. Formüllerde Hücre Adreslerini Kullanmak

4 Uygulama 1’ de her öğrencinin not ortalamasını hesaplatmak için not ortalamaları girildi. Eğer öğrenci sayısı 3 değil de 500 olsaydı bu iş bir işkence olacaktı. Microsoft Excel’in bu tip durumlar içinde önerdiği bir çözüm vardır. Tek tek tüm hücrelere formül girmek yerine sadece ilk hücreye formül girilir. Daha sonra formülün girildiği hücrenin üzerine gelip fare imlecini hücrenin sağ alt köşesine götürürüz. Fare imleci siyah bir artı işaretine dönüştükten sonra sol düğme basılı tutularak aşağı doğru çekilir. Bu şekilde istenen hücrelere formülü atamış oluruz. Otomatik formül çoğaltmada ilk formül referans alınır ve her bir alt satırda formül içerisinde geçen hücre adları bir artırılır. (Ayrıca Ders) Eğer formül çoğaltmada formül içerisinde bir hücre adının sabit kalması istenirse hücre adı yazılırken $ işaretleri ile beraber yazılır. Uygulama -2 deki tabloyu inceleyebilirsiniz. Formülleri Otomatik Çoğaltmak

5 Bu uygulamada satmış olduğumuz ürünlerin bir listesi bulunmaktadır. Kar Marjı adlı bölüme yani F2 hücresine gireceğimiz rakam oranında satış fiyatları hesaplanmasını istiyoruz. Yani tüm ürünlerin fiyatı hesaplanırken F1 hücresi sabit olarak kullanılacak. =B2 + (B2*F1%) formülü sadece B2 ( TL.) yüzde F1’ini (10) hesaplayacak. Aynı zamanda F1’ in formül çoğaltmada sabit kalmasını istediğim için $ işaretleri arasında yazmamız gerekecek. C2 hücresine girilecek formül şu olmalıdır; =B2+(B2*$F$1%) UYGULAMA – 2a

6 Çarpım Tablosu $A3: A 3'deki değer sabit kalır. B$2: 2. Satırdaki değerler sabit kalır. B3 adresli Hücreye uygulanan Fonksiyonu kopyalayarak diğer boş yerlere yapıştırabilirsiniz. Formülleri Otomatik Çoğaltmak UYGULAMA – 2b

7 Hatırlatma : Microsoft Excel’de her çalışma kitabı 3 adet sayfa ile açılır. Bu sayfaları artırabilir veya azaltabiliriz. Yeni bir çalışma sayfası oluşturmak için Ekle-Çalışma Sayfası (Insert-Work Sheet) komutu verilir. Varolan bir sayfayı silmek için Düzen-Sayfayı Sil (Edit- Delete-Sheet) komutu verilir. Aktif sayfanın adını değiştirmek için sayfa adı üzerine çift tıklayabilir veya Biçim-Sayfa- Yeniden Adlandır (Format-Sheet-Rename) komutu verilir. Farklı Çalışma Sayfalarındaki Verileri Kullanmak  Farklı bir sayfadan veri alınırken SayfaAdı!HücreAdı kalıbı kullanılır.

8 Yukarıda bir çalışma kitabında bulunan 3 adet farklı sayfa görülmektedir. EV sayfasında ev için yapılan harcamalar, İŞ sayfasında işyeri için yapılan harcamalar ve TOPLAM sayfasında ev ve işyeri için yapılan harcamaların toplamını hesaplayacağımızı varsayalım. Buna göre sayfalara gireceğimiz formüller şu şekilde olmalıdır.  Ev için yapılan toplam harcama miktarını görebilmek için EV sayfasında B4 hücresine şu formülü girmeliyiz; =B1+B2+B3 yada; =TOPLA(B1:B3) sonuç TL. çıkar  İş için yapılan toplam harcama miktarını görebilmek için İŞ sayfasında B4 hücresine şu formülü girmeliyiz; =B1+B2+B3 yada; =TOPLA(B1:B3) sonuç TL. çıkar  TOPLAM sayfasında ise ev ve işyeri için ödenen meblağları bulmak için gireceğimiz formül şöyle olmalıdır; B1 hücresi için=EV!B1+İŞ!B1sonuç TL. çıkar B2 hücresi için=EV!B2+İŞ!B2sonuç TL. çıkar B3 hücresi için=EV!B3+İŞ!B3sonuç TL. çıkar B4 hücresi için=EV!B4+İŞ!B4sonuç TL. çıkar NOT : Eğer sayfa adı boşluk içeriyorsa formül içerisinde sayfa adı yazılırken tırnak ( ‘ ) içerisinde yazılmalıdır. Farklı Çalışma Sayfalarındaki Verileri Kullanmak UYGULAMA – 3

9 Microsoft Excel’de yaptığımız işlemlerimizde bulunan yanlışlıklara karşın değişik hata mesajları ile karşılaşırız. Bu hatanın anlamını bildiğimiz takdirde düzeltmemiz daha kolay olur. ###### Hatası Uyguladığınız formül sonucunun hücreye sığmayacak kadar büyük olması durumunda görülür. Sütun genişliğini ayarlayarak sorunu giderebiliriz #SAYI/O Hatası Sıfıra bölme hatasıdır. Bölen olarak 0’dan (sıfır) daha farklı bir rakamın girilmesi ile düzeltilebilir. #AD ? Hatası Formüldeki girilen metnin tanınmadığı durumda bu hata ile karşılaşırız. Formül adının yanlış yazılması halinde veya formül içerisindeki metnin çift tırnak içinde girilmemesi durumunda gelen bir hata mesajıdır. Formül düzeltilğinde hata giderilir. #YOK Hatası Değer bulunamaması durumunda oluşan bir hatadır. Formül içine değişkenler girilmelidir. #SAYI Hatası Bir sayı ile ilgili problem oluştuğunda oluşur. Microsoft Excel’de gösterilemeyecek kadar büyük veya küçük sayı üreten formüllerde bu hata ile karşılaşırız. #DEĞER Hatası Sayı veya mantıksal fonksiyon girilmesi gereken yere metin girilmesi durumunda oluşur. Hatalar

10 Microsoft Excel’de bir hücrenin alabileceği değere göre farklı işlemler yaptırmamız mümkündür. Bunu yapabilmemiz karşılaştırma operatörlerinden faydalanırız. Microsoft Excel’de kullanılan karşılaştırma operatörleri şunlardır. >Büyüktür >=Büyük eşittir Eşit değildir Microsoft Excel’de karşılaştırma operatörlerini kullanmak için Eğer (If) adında bir fonksiyon bulunmaktadır. Bu formülün kalıbı EĞER(KOŞUL;DOĞRU;YANLIŞ) şeklindedir. Bu fonksiyonda bir koşul belirtilir ve bu koşul doğru çıkması veya yanlış çıkmasına göre bir işlem yapılır. Karşılaştırmaları Kullanmak

11 Değerler ve formüller üzerinde koşula bağlı testler yapmak için "Eğer" (IF) fonksiyonunu kullanırız. Belirlediğiniz koşulun sonucu "Doğru" ise bir değeri, "Yanlış" ise başka bir değeri verir. Bu fonksiyon dışarıdan parametre olarak üç bilgi almaktadır. İlk parametrede bir karşılaştırma bulunmaktadır. Karşılaştırmanın sonucu doğru değerini içeriyorsa "Eğer" fonksiyonu geriye kendisine 2. parametre olarak verilen bilgiyi, karşılaştırmanın sonucu yanlış ise "Eğer" fonksiyonu bu kez 3.parametreyi geriye döndürür. Eğer Fonksiyonu EĞER (IF) FONKSİYONUNUN KULLANIMI.. DİKKAT! Açılan ve kapatılan parantez sayıları birbirine eşit olmalı. Karakterler çift tırnak içinde gösterilmeli. Sayılar çift tırnak içine alınmaz. Doğru ya da yanlış değer verilmeyecekse noktalı virgül mutlaka konulmalıdır.

12 Öğrenci notlarını girdiğimiz bir tablomuz olsun. Bu tabloda öğrencilerin not ortalamasına göre GEÇTİ veya KALDI yazmasını istiyorsak EĞER ( IF ) fonksiyonunu kullanmalıyız. Karşılaştırmaları Kullanmak UYGULAMA – 4 Bu tabloda ilk önce öğrenci not ortalamalarını hesaplatmak için D sütununda ortalamaları hesaplayan bir formül girmeliyiz. Buna göre D2 hücresine ; =(B2+C2)/2 yada =ORTALAMA(B2:C2) formülünü girmeliyiz. Bu şekilde tüm öğrencilerin not ortalamaları hesaplandıktan sonra, E sütununda geçti kaldı durumlarını hesaplatmak için şu formüller girilmelidir; E2 hücresine =EĞER(D2>=50;”GEÇTİ”;”KALDI”) E3 hücresine =EĞER(D3>=50;”GEÇTİ”;”KALDI”) E4 hücresine =EĞER(D4>=50;”GEÇTİ”;”KALDI”) Formül içerisinde geçen GEÇTİ ve KALDI metinlerinin tırnak içerisinde yazıldığına dikkat edin. Bir formül içerisinde eğer metin kullanılıyorsa kesinlikle tırnak içerisinde yazılmalıdır. Bu formülü biraz daha genişletmek istersek yani geçti kaldı değil de öğrenci not ortalaması 85 üzerinde ise TAKDİR, arasında ise TEŞEKKÜR, arasında ise GEÇTİ, 50’nin altında ise KALDI yazmasını istersek formülümüz şu şekilde olmalıdır.( İç İçe EĞER (IF) kullanımı ) =EĞER(D2>=85;”TAKDİR”;EĞER(D2>=75;”TEŞEKKÜR”;EĞER(D2>=50;”GEÇTİ”;”KALDI”)))


"HESAP TABLOSU PROGRAMLARI BİLGİSAYAR ORTAMINDA YARATILAN ELEKTRONİK ÇALIŞMA SAYFALARI." indir ppt

Benzer bir sunumlar


Google Reklamları